Etch on Optiplex 320

Jason Ronallo jronallo at gmail.com
Tue Jan 9 09:13:09 CST 2007


Oh! I forgot to mention one very important detail! Do not install
GRUB. I haven't followed up yet, but there seems to be a problem with
GRUB. Instead back out of the GRUB installation during your Etch
install and you get to a menu showing all the steps of a Debian
install. Install LILO instead. LILO works.

For the rest see my previous message below.

--Jason

---------- Forwarded message ----------
From: Jason Ronallo <jronallo at gmail.com>
Date: Jan 9, 2007 10:03 AM
Subject: Re: FW: Optiplex 320
To: linux-desktops at dell.com


I've been able to install Debian Etch with the RC1 installer on an
Optiplex 320n. I'm not sure whether I had to pass the pci=nomsi boot
parameter, but that seems reasonable. I hope to have a chance to post
a fuller write up but here's something quick without being in front of
that machine:

On boot X will fail complaining that there is no kbd or mouse support.
After the errors you get a login prompt. Installing 3 packages and
changing one parameter in xorg.conf fixes it.

>su
#apt-get install xserver-xorg-video-ati xserver-xorg-input-kbd
xserver-xorg-input-mouse

Then in /etc/X11/xorg.conf edit the driver under ATI Radeon to be:
   Driver         "radeon"

Then reboot (or startx, logout of root, at gdm login as user).

That worked for me and hope it works for someone else.  I'll be
reinstalling Etch on an Optiplex 320 in the next few days to try a
RAID1 configuration.

I thought I read in another forum that Fedora Core 6 also worked on
the Optiplex 320.

--Jason



More information about the Linux-Desktops mailing list