ACPI BIOS problem

Aaron drizzt321 at shackmail.com
Sun Dec 24 00:48:18 CST 2006


Since there is no linux-notebook, I'm going to try posting to here with 
a problem with the Inspiron e1505/6400 series. I'm running with the 
latest A12 BIOS, which still has the problem.

I am trying to use the Expresscard slot ( http://www.expresscard.org ) 
on the PCI-Express bus with an eSata card. If I have the card plugged in 
when the system boots, no problems, everything is hunky dory. If I try 
to hotplug the card after the system has already been up and running 
(yes, I have verified the hardware supports this, both the chipset and 
card) I am unable to. I have tried the pciehp (pci-express hotplug) 
drivers, which don't work because Dell has not implemented the _OSC ACPI 
function. I have verified this with the Intel engineer which maintains 
the driver. I have also tried the acpiphp driver, which doesn't work 
either. Anyone, hopefully a Dell engineer reading this, able to tell me 
how I am supposed to get hotplug working on pci-express?

Oh, and just to let you all know, it works under XP because XP uses a 
different way, although Vista does use the correct _OSC function call as 
described in 
http://www.microsoft.com/whdc/system/bus/pci/BIOS_HotPlugPCIe.mspx which 
I found in my research on the net.

Aaron



More information about the Linux-Desktops mailing list