Linux on the XPS M2010 80% success

Rune Nilsen rune at 9ls1.com
Thu Dec 7 13:39:42 CST 2006


I have got myself an XPS M2010 and have installed 64-bit Linux on it.
It is a monster laptop in every sense of the word: 

* Core 2 Duo 2.16GHz, 2GB RAM
* ATI X1800
* 20.1" reflective LCD-screen
* 2 x 120 GB 5400rpm disks with Intel software raid
* Detachable bluetooth keyboard
* 3+ hours battery life
* Only 8.5 kg :-/

A few issues I have solved:

* I tried different distros, but Fedora Core 6 (x86_64) was the only one I 
found which supported a RAID 0 setup from the install cd (I had set up RAID 0 
from Windows before installing Linux).

* Use the ipw3945 proprietary driver for the Intel wireless card.

* By using the ATI proprietary driver fglrx, both suspend and hibernate works 
fine. But hibernate hangs if I have an SD card in the built-in card reader...

This is what I haven't fixed yet:

* The ALSA sound driver (Intel HDA) seems to work, but there is no sound from 
the internal speakers. Using headphones works. I googled a lot for similar 
problems, and found others who use the model=ref or model=3stack module 
options, but there is no effect.

Can anyone help me with this?

* No bluetooth device can be found. I assume that is because the Dell BIOS 
emulates USB for the keyboard and the mouse.
* The keyboard worked very strangely, with double and missing chars. I have 
changed my xorg.conf to use the old keyboard driver (Section "InputDevice": 
Driver "keyboard" instead of "kbd"), and that helped a lot, but two issues 
remain:

   - There are still some missing chars now and then
   - The keyboard goes to sleep after a period of inactivity. Every time it 
     wakes up again, the first key repeats endlessly until i hit another key.

I assume these are connected, and that the problem lies in using the BIOS USB 
emulation, but I can't figure out how to get linux to use regular bluetooth 
instead.

Anyone have any tips for this?

Thanks!

-- 
Rune Nilsen



More information about the Linux-Desktops mailing list