BIOS update on Studio 1558

Brian Burch brian at PingToo.com
Sun May 1 07:30:14 CDT 2011


On 28/02/11 12:57, Sriram Chadalavada wrote:
> linuxsri at linuxsri-laptop:~/Downloads$ sudo update_firmware
>
> Running system inventory...
>
> Searching storage directory for available BIOS updates...
> Checking System BIOS for Studio 1558 - *a04*
>      Did not find a newer package to install that meets all installation
> checks.
>
> This system does not appear to have any updates available.
> No action necessary.
>
>   However, the Windows BIOS installer talks about version *A11*. Clearly
> my BIOS is out of date.
>
> 2. These appear to to be the system and device IDs.
>
> system_bios(ven_0x1028_dev_0x0413)/system(ven_0x1028_dev_0x0413)
> system_bios(ven_0x1028_dev_0x0413)
>
>   On the page http://linux.dell.com/repo/firmware/bios-hdrs/, there is
> no corresponding entry for any version of BIOS. Would that be why the
> system does not see any updates or did I just understand this completely
> wrong?

The Dell repository now has bios A12 available (8/04/2011).

My machine has locked up more often with each new linux kernel, so I 
decided to apply A12 any way that I could.

I have an old compaq laptop XP image running under VMWare, but that 
didn't help me run the windows bios update for my dell because (of 
course) the WinPhlash program could only detect the vmware bios, not the 
real one.

I tried messing around with PEBuilder and giving it my compaq oem XP 
recovery CD as the installer feed, but it kept giving me errors creating 
the CD, and it wouldn't boot.

Finally, I stumbled into a very scary procedure for building a bootable 
freedos system to update the bios. You have to run the R301434.EXE 
self-extracting program under wine, then run the unpacked 1558_A12.EXE 
under wine to create a standalone copy of BIOS1.WPH (the bios upgrade 
image file).

Next, you download and unpack a dos 16-bit bios flash program from the 
dell ftp site by finding a package for an older system. You run freedos 
in a qemu virtual machine to create a bootable system on a usb memory 
stick, then add the old dos flash utility and the new bios image. Boot 
your dell studio 1558 from the usb device and run the flash16 program... 
sit around nervously while the status is updated and it beeps a lot. 
Eventually the process completes and the system reboots with the new 
bios active.

Here is the full procedure:

http://www.ruzee.com/blog/2010/01/dell-studio-15-bios-update-with-linux

It is a scary process and I'm very relieved to say it worked for me. As 
Matt has said on this and several other threads, dell are distributing 
bios updates for more and more of their models in this "new" 
windows-only format.

I guess the 1558 won't have many (any?) more BIOS updates, so I'll 
probably survive for years running A12. I only bought a Dell this time 
because I believed they had started to recognise the value of selling 
machines to linux-only users. The move back to windows-only maintenance 
will make me tell anyone who will listen to keep away from linux on dell 
in future.

Good luck!

Brian


More information about the firmware-tools-devel mailing list