Cannot find packages

Colin Schuster colin.schuster at gmail.com
Fri Jul 28 08:27:41 CDT 2006


Must be my version of yum (2.0.7) because up2date workes like a charm.
Thanks for your help!

On 7/27/06, Michael_E_Brown at dell.com <Michael_E_Brown at dell.com> wrote:
>
>  Which version of 'yum' do you have installed? It is possible that it is
> too old to do the automatic dependency installs given a package virtual
> provides. For RHEL installs, I generally only ever test with up2date,
> because it comes installed by default and yum is not normally installed.
> --
> Michael
>
>  ------------------------------
> *From:* Colin Schuster [mailto:colin.schuster at gmail.com]
> *Sent:* Thursday, July 27, 2006 1:28 PM
> *To:* Brown, Michael E
> *Cc:* firmware-tools-devel at lists.us.dell.com
> *Subject:* Re: Cannot find packages
>
> Yes, this worked (I didn't actually complete the install, but it did not
> give me any errors).
>
> On 7/27/06, Michael_E_Brown at dell.com <Michael_E_Brown at dell.com> wrote:
> >
> > I see the package in the yum metadata, so I cannot see a reason why it
> > would not find the package. Can you just try directly installing with:
> >   yum install system_bios_ven_0x1028_dev_0x016c
> >
> > --
> > Michael
> >
> >
> > -----Original Message-----
> > From: firmware-tools-devel-bounces at lists.us.dell.com on behalf of Michael_E_Brown at dell.com
> >
> > Sent: Thu 7/27/2006 12:41 PM
> > To: colin.schuster at gmail.com; firmware-tools-devel at lists.us.dell.com
> > Subject: RE: Cannot find packages
> >
> > It is completely normal to see a several "Cannot find package" messages.
> > The inventory tool lists all possible firmware it can find, but there may
> > not necessarily be corresponding firmware images in the repository.
> >
> > What is a bit mysterious is that it cannot find a
> > system_bios(ven_0x1028_dev_0x016c) image, which should be there. I just
> > checked and the RPM is there:
> >
> > [michael_e_brown at lists RPMS]$ ls *0x016c*
> > system_bios_ven_0x1028_dev_0x016c- a05-14.1.noarch.rpm
> > [michael_e_brown at lists RPMS]$ rpm -qp --provides
> > system_bios_ven_0x1028_dev_0x016c-a05-14.1.noarch.rpm warning:
> > system_bios_ven_0x1028_dev_0x016c-a05-14.1.noarch.rpm: V3 DSA signature:
> > NOKEY, key ID 5e3d7775
> > system_bios(ven_0x1028_dev_0x016c) = a05
> > system_bios_ven_0x1028_dev_0x016c = a05-14.1
> >
> > That is a bit odd and deserves exploration. I will check the repo.
> > --
> > Michael
> >
> > -----Original Message-----
> > From: firmware-tools-devel-bounces at lists.us.dell.com on behalf of Colin
> > Schuster
> > Sent: Thu 7/27/2006 11:21 AM
> > To: firmware-tools-devel at lists.us.dell.com
> > Subject: Cannot find packages
> >
> > Hi,
> >
> > I am trying to update the firmware on my Dell 1850 running RHEL3.  I
> > have
> > configured my yum repository to url
> > "baseurl= http://repo.fwupdate.com/repo/firmware/cross-distro
> > ", however I am seeing the following errors:
> >
> > yum install $(inventory_firmware -b)
> > Gathering header information file(s) from server(s)
> > Server: Dell Software
> > Server: Firmware updates
> > Finding updated packages
> > Downloading needed headers
> > Cannot find a package matching system_bios(ven_0x1028_dev_0x016c)
> > Cannot find a package matching bmc_firmware(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> >
> > pci_firmware(ven_0x8086_dev_0x3590_subven_0x3590_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x3595)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x3597)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x3598)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x3599)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> >
> > pci_firmware(ven_0x8086_dev_0x24d2_subven_0x24d2_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> >
> > pci_firmware(ven_0x8086_dev_0x24d4_subven_0x24d4_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> >
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x24d7_subven_0x24d7_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> >
> > Cannot find a package matching
> >
> > pci_firmware(ven_0x8086_dev_0x24dd_subven_0x24dd_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> >
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x244e)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x24d0)/system(ven_0x1028_dev_0x016c)
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x24db_subven_0x24db_subdev_0x016c)/system(ven_0x1028_dev_0x016c)
> >
> >
> > Cannot find a package matching
> > pci_firmware(ven_0x8086_dev_0x0330)/system(ven_0x1028_dev_0x016c)
> >
> >
> > The same thing happened when I attempted to create a local repo of
> > fwupdate.
> >
> >
> > Any thoughts?
> >
> > Thanks in advance..
> >
> > Colin
> >
> > _______________________________________________
> > firmware-tools-devel mailing list
> > firmware-tools-devel at lists.us.dell.com
> > http://lists.us.dell.com/mailman/listinfo/firmware-tools-devel
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/firmware-tools-devel/attachments/20060728/3b25e454/attachment.htm 


More information about the firmware-tools-devel mailing list