DKMS and RHEL smp kernels

Akemi Yagi amyagi at gmail.com
Mon Jul 16 11:03:38 CDT 2007


On 7/16/07, Neil Hodge <hodge3 at llnl.gov> wrote:
> All:
>
> I would like to be running the latest RHEL 4 smp kernel, but I can't get
> DKMS to load the nvidia drivers properly.  I have looked at all of the
> online information that I can find, and it seems that various things
> that are necessary for DKMS to work are missing, e.g., there is no
> /lib/module/kernel-version/build symlink.
>
> Any idea why DKMS would work straight out of the box for the vanilla
> kernel, and not for the smp kernel?
>
> Thanks.
>
> Neil Hodge
> hodge3 at llnl.gov

I suggest you enable the rpmforge repo and install dkms and the
nvidia-related rpm's  from there.  They should work out of the box.

Akemi



More information about the DKMS-devel mailing list