[Crowbar] Deploying Nova

japhar81 japhar81 at gmail.com
Mon Jan 30 11:28:44 CST 2012


I have two total nodes -- one is admin, the other is everything else.
Currently it has mysql, glance, keystone, and nova-dashboard (i was working
top-down as the page instructs). Last thing im putting on it is nova. Thats
whats failing.

On Mon, Jan 30, 2012 at 11:32 AM, <Andi_Abes at dell.com> wrote:

> What roles did you allocate to this node?****
>
> And just to clarify, is this node just an admin? Or is this 2 nodes –
> admin and another one?****
>
> ** **
>
> *From:* japhar81 [mailto:japhar81 at gmail.com]
> *Sent:* Monday, January 30, 2012 11:24 AM
> *To:* Abes, Andi
> *Cc:* crowbar
> *Subject:* Re: [Crowbar] Deploying Nova****
>
> ** **
>
> There is (currently) only one node. However, it is allocated, installed
> the OS, and went green. It also went green after mysql, again after
> keystone, etc. its just nova that freezes.. Are you saying start over? I
> can just nuke the node and re-start I guess, but I've done that a few times
> with the same results****
>
> On Mon, Jan 30, 2012 at 11:19 AM, <Andi_Abes at dell.com> wrote:****
>
> One way to troubleshoot this could be to manually allocate all the nodes,
> before you're trying to install  nova.
> To do that - in the UI go to Nodes, Bulk Edit and click all the
> checkboxes, then hit save.
> The nodes will start installing the operating system.
> Make sure all the nodes turn green, and if not, trouble shoot the ones
> that haven't. (this could take a while.... Installing the OS)
> Once that's done, go through the normal proposal path****
>
>
> From: crowbar-bounces On Behalf Of japhar81****
>
> Sent: Monday, January 30, 2012 10:43 AM
> To: Abes, Andi****
>
> Cc: crowbar
> Subject: Re: [Crowbar] Deploying Nova****
>
> Looking further up in the log, i noticed it was missing crowbar.rb -- i
> copied that from the admin node, and that error doesn't show up anymore,
> but the results are the same, chef-client just freezes.****
>
> On Sun, Jan 29, 2012 at 5:07 PM, japhar81 <japhar81 at gmail.com<mailto:
> japhar81 at gmail.com>> wrote:
> I can't really tell what the actual problem is, but what i see is my admin
> node comes up fine, and my one test node PXE boots and deploys. Im able to
> run down the openstack list (mysql, keystone, glance, dashboard) with no
> issue. But once I hit Nova, it just freezes mid-deploy. Node shows unready,
> barclamp shows pending, and the logs show what you see in the thread. I
> just cant get nova to finish deploying and start.****
>
> On Sun, Jan 29, 2012 at 4:37 PM, <Andi_Abes at dell.com<mailto:
> Andi_Abes at dell.com>> wrote:
> This seems ok.... What's the actual problem with this ISO?
>
> From: crowbar-bounces On Behalf Of japhar81
> Sent: Sunday, January 29, 2012 10:13 AM
> To: Althaus, Gregory
> Cc: crowbar
> Subject: Re: [Crowbar] Deploying Nova
>
> Not sure this helps much, but here's the output.. IPMI is turned off since
> im using HP/iLO, and i did rebuild the latest iso last week for a tcpdump
> fix. But this log doesn't seem to have anything to do with either one?
>
> /usr/lib/ruby/vendor_ruby/chef/application.rb:67:in `run'
> /usr/bin/chef-client:25
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Loading plugin crowbar
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Loading Recipe kernel-panic via
> include_recipe
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Found recipe default in cookbook
> kernel-panic
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Loading Recipe
> ipmi::ipmi-configure via include_recipe
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Found recipe ipmi-configure in
> cookbook ipmi
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Loading Recipe utils via
> include_recipe
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Found recipe default in cookbook
> utils
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Loading Recipe network via
> include_recipe
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: Found recipe default in cookbook
> network
> [Sun, 29 Jan 2012 04:10:21 -0600] DEBUG: I am not loading utils, because I
> have already seen it.****
>
> On Sat, Jan 28, 2012 at 10:16 AM, <Gregory_Althaus at dell.com<mailto:
> Gregory_Althaus at dell.com><mailto:Gregory_Althaus at dell.com<mailto:
> Gregory_Althaus at dell.com>>> wrote:
> This might mean that it is stuck trying to run tcpdump or some ipmi
> discovery piece.
>
> Chef-client -l debug on that node might turn up more info.
>
> Thanks,
> Greg
>
> From: crowbar-bounces On Behalf Of japhar81
> Sent: Friday, January 27, 2012 8:34 PM
> To: crowbar
> Subject: [Crowbar] Deploying Nova
>
> Hello all, still having issues pushing nova.. I see the below in the logs,
> it's been stuck here for a few hours. The UI shows the node as 'Applying'
> and the barclamp as 'Pending'. I tried rebooting the node, but that caused
> everything go wonky last time, so I started all over, but im at the same
> point. Has anyone seen this before? Any suggestions?
>
> [Fri, 27 Jan 2012 10:22:04 -0600] INFO: Start handlers complete.
> [Fri, 27 Jan 2012 10:22:04 -0600] INFO: Loading cookbooks [apache2,
> barclamp, bluepill, ganglia, glance, ipmi, kernel-panic, keystone, logging,
> mysql, nagios, network, nova, nova_dashboard, ntp, ohai, openssl,
> provisioner, rabbitmq, repos, resolver, utils]
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: ohai plugins will be at:
> /etc/chef/ohai_plugins
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: Processing directory[/opt/tcpdump]
> action create (ohai::default line 23)
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: Processing
> directory[/etc/chef/ohai_plugins] action create (ohai::default line 45)
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: Processing
> remote_directory[/etc/chef/ohai_plugins] action create (ohai::default line
> 54)
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: Processing
> cookbook_file[/etc/chef/ohai_plugins/crowbar.rb] action create (dynamically
> defined)
> [Fri, 27 Jan 2012 10:22:05 -0600] INFO: Processing
> cookbook_file[/etc/chef/ohai_plugins/README] action create (dynamically
> defined)
>
> ****
>
> ** **
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/crowbar/attachments/20120130/816566dc/attachment.html 


More information about the Crowbar mailing list