[Crowbar] Stuck in Readying

japhar81 japhar81 at gmail.com
Tue Jan 24 14:56:55 CST 2012


Now failing on MySql -- what am i missing?

[Tue, 24 Jan 2012 14:55:07 -0600] INFO: Report handlers complete
stdin: is not a tty
[Tue, 24 Jan 2012 14:55:14 -0600] INFO: *** Chef 0.10.8 ***
[Tue, 24 Jan 2012 14:55:15 -0600] INFO: HTTP Request Returned 404 Not
Found: Cannot load role mysql-config-MySql
[Tue, 24 Jan 2012 14:55:15 -0600] ERROR: Role mysql-config-MySql is in the
runlist but does not exist. Skipping expand.
[Tue, 24 Jan 2012 14:55:15 -0600] FATAL: Stacktrace dumped to
/var/cache/chef/chef-stacktrace.out
[Tue, 24 Jan 2012 14:55:15 -0600] FATAL: Chef::Exceptions::MissingRole:
Chef::Exceptions::MissingRole
stdin: is not a tty
[Tue, 24 Jan 2012 14:55:16 -0600] INFO: *** Chef 0.10.8 ***
[Tue, 24 Jan 2012 14:55:17 -0600] INFO: HTTP Request Returned 404 Not
Found: Cannot load role mysql-config-MySql
[Tue, 24 Jan 2012 14:55:17 -0600] ERROR: Role mysql-config-MySql is in the
runlist but does not exist. Skipping expand.
[Tue, 24 Jan 2012 14:55:17 -0600] FATAL: Stacktrace dumped to
/var/cache/chef/chef-stacktrace.out
[Tue, 24 Jan 2012 14:55:17 -0600] FATAL: Chef::Exceptions::MissingRole:
Chef::Exceptions::MissingRole


On Tue, Jan 24, 2012 at 3:34 PM, japhar81 <japhar81 at gmail.com> wrote:

> I did -- it didn't work. I just restarted -- nuked both nodes and re-PXE'd
> them. I've gone through and created proposals for Keystone, Glance, MySql,
> Nova, and Nova Dashboard. They're applying now, guess we'll see in a few
> minutes
>
>
> On Tue, Jan 24, 2012 at 3:28 PM, <Gregory_Althaus at dell.com> wrote:
>
>> Did you create glance?****
>>
>> ** **
>>
>> Thanks,****
>>
>> Greg****
>>
>> ** **
>>
>> *From:* japhar81 [mailto:japhar81 at gmail.com]
>> *Sent:* Tuesday, January 24, 2012 1:34 PM
>>
>> *To:* Althaus, Gregory
>> *Cc:* crowbar
>> *Subject:* Re: [Crowbar] Stuck in Readying****
>>
>> ** **
>>
>> Reboot did the same thing.. I then did a 'reinstall' on both nodes and
>> PXE booted them to start all over. It did that, pulled down mysql and
>> keystone (both show active) but is in the same place on nova and nova
>> dashboard..****
>>
>> ** **
>>
>> Added bonus: this time the admin node has nothing in
>> /opt/dell/crowbar_framework/log -- it didnt even create the files this time
>> ****
>>
>> On Tue, Jan 24, 2012 at 2:10 PM, <Gregory_Althaus at dell.com> wrote:****
>>
>> Because I don’t know if they have completely showed up.****
>>
>>  ****
>>
>> Thanks,****
>>
>> Greg****
>>
>>  ****
>>
>> *From:* crowbar-bounces *On Behalf Of *Althaus, Gregory
>> *Sent:* Tuesday, January 24, 2012 1:10 PM
>> *To:* japhar81 at gmail.com****
>>
>>
>> *Cc:* crowbar
>> *Subject:* Re: [Crowbar] Stuck in Readying****
>>
>>  ****
>>
>> I’d reboot them both again.****
>>
>>  ****
>>
>> Thanks,****
>>
>> Greg****
>>
>>  ****
>>
>> *From:* japhar81 [mailto:japhar81 at gmail.com]
>> *Sent:* Tuesday, January 24, 2012 1:04 PM
>> *To:* Althaus, Gregory
>> *Cc:* crowbar
>> *Subject:* Re: [Crowbar] Stuck in Readying****
>>
>>  ****
>>
>> So one box is showing ssh: connect to host port 22: connection refused in
>> /opt/dell/crowbar_framework/log, the other isnt showing any errors. And the
>> other logs appear to be clean. The two nodes are alternating on the
>> dashboard between readying and unready, and my proposals for nova and
>> nova-dashboard are both in 'pending'..****
>>
>>  ****
>>
>> Anything else I need to do? Should I reboot them? Do they need to PXE
>> boot again?****
>>
>> On Tue, Jan 24, 2012 at 1:57 PM, <Gregory_Althaus at dell.com> wrote:****
>>
>> When a proposal is being applied, the logs for those chef-client runs go
>> to:
>> /opt/dell/crowbar_framework/log/<machine name>.log
>>
>> You can also look at /var/log/messages or /var/log/syslog on the admin
>> node to see if the system is having issues.
>>
>> You can also check /var/log/crowbar_join* on the node that is "stuck".
>>
>> Thnaks,
>> Greg
>>
>> From: crowbar-bounces On Behalf Of japhar81
>> Sent: Tuesday, January 24, 2012 12:20 PM
>> To: crowbar
>> Subject: [Crowbar] Stuck in Readying****
>>
>>
>> Hello all,
>> Making some headway with my install, I've got two nodes joined to my
>> admin node. I was able to push out keystone, mysql, and glance without much
>> issue. I then pushed nova-compute. It has been stuck in 'readying' for
>> several hours, and doesn't seem to be moving.
>>
>> Is there some way to monitor what it's doing and whether or not it's
>> stuck/failed somewhere? Basically how do I tell what's going on and why
>> it's still in 'readying'?****
>>
>>  ****
>>
>> ** **
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/crowbar/attachments/20120124/deee82a5/attachment.html 


More information about the Crowbar mailing list