[Crowbar] Building sledgehammer failing?

japhar81 japhar81 at gmail.com
Mon Jan 23 12:05:23 CST 2012


I did have the ISO provided -- in re-reading the output I discovered an
error that the port was already in use -- nuked that PID and I'm set!

On Mon, Jan 23, 2012 at 12:35 PM, <Gregory_Althaus at dell.com> wrote:

> Make sure that you have a centos 5.7 iso in your build cache or set the
> CENTOS_ISO env to a path to that image.
>
> Thanks,
> Greg
>
> From: crowbar-bounces On Behalf Of japhar81
> Sent: Monday, January 23, 2012 11:28 AM
> To: crowbar
> Subject: [Crowbar] Building sledgehammer failing?
>
> Im trying to re-build the ISO for crowbar/openstack from latest again to
> get the bug fix I need from last week. I just ran ./build_sledgehammer.sh,
> and got the following. I've tried deleting the crowbar-sledgehammer folder
> entirely and restarting from git, but same results.. have i hit a bug? Is
> there something Im doing wrong?
>
> http://127.0.0.1:54321/repodata/repomd.xml: [Errno -1] Error importing
> repomd.xml for redhat-base: Damaged repomd.xml file
> Trying other mirror.
> Error: Cannot retrieve repository metadata (repomd.xml) for repository:
> redhat-base. Please verify its path and try again
> /bin/sed: can't read
> /usr/lib/python2.4/site-packages/imgcreate/creator.py: No such file or
> directory
> /bin/mv: cannot stat `/sbin/mksquashfs': No such file or directory
> /bin/chmod: cannot access `/sbin/mksquashfs.orig': No such file or
> directory
> /bin/bash: /usr/bin/livecd-creator: No such file or directory
> Could not build full iso image
> ./build_sledgehammer.sh: line 55: kill: (9814) - No such process
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/crowbar/attachments/20120123/7afd8d43/attachment.html 


More information about the Crowbar mailing list