[Crowbar] Router_pref backport

Kevin Bringard kbringard at atti.com
Tue Jan 17 17:10:23 CST 2012


Yea, I'm looking at the admin node and I see my changes are there. I did
make a couple of changes after build, like adding some debug messages, and
knifed them in, but they took effect because the logging I added output...
I still see the router_pref schema/json in place as well as the
router_pref code block in default.rb, again all on the admin node.

But anyway, I guess the important bit is, there shouldn't be anything that
I need to change elsewhere, correct? Like in the crowbar barclamp to push
changes upstream via node or anything like that?

Thanks for the help!

-- Kevin

On 1/17/12 4:04 PM, "Andi_Abes at Dell.com" <Andi_Abes at Dell.com> wrote:

>This sounds more a build issue, rather than something specific to the
>network bc.
>
>Only thing I can come up with is - check your changes are still there,
>committed in git. The build script plays some hokey tricks with git, that
>might toss away uncommitted changes.
>
>
>-----Original Message-----
>From: crowbar-bounces On Behalf Of Kevin Bringard
>Sent: Tuesday, January 17, 2012 5:57 PM
>To: crowbar
>Subject: Re: [Crowbar] Router_pref backport
>
>I made the changes and then built a new iso, installed it, etc... But
>again, the only changes I made were in the network barclamp.
>
>I can send you the output of the hashes if it would be helpful
>
>On 1/17/12 3:54 PM, "Andi_Abes at Dell.com" <Andi_Abes at Dell.com> wrote:
>
>>The network barclamp gets instantiated during admin node install time.
>>Did you apply the changes you're describing on top of an existing admin
>>node, or did you build a new ISO + node?
>>
>>-----Original Message-----
>>From: crowbar-bounces On Behalf Of Kevin Bringard
>>Sent: Tuesday, January 17, 2012 5:53 PM
>>To: crowbar
>>Subject: [Crowbar] Router_pref backport
>>
>>Hey guys,
>>
>>I'm trying to backport the router_pref setting to the v1.2 release, but
>>I'm having some trouble. I've added the requisite code in the network
>>barclamp (basically, I checked out HEAD on that submodule and manually
>>copied it into place). It all seems to work, however in the network
>>hash router_pref isn't one of the keys. I've added it to the json and
>>schema, but it just isn't being built into the hash for some reason.
>>
>>Perhaps there is something else in the crowbar framework in the node
>>setup that I'm missing? Any ideas?
>>
>>Thanks!
>>
>>-- Kevin
>>
>>_______________________________________________
>>Crowbar mailing list
>>Crowbar at dell.com
>>https://lists.us.dell.com/mailman/listinfo/crowbar
>>For more information: https://github.com/dellcloudedge/crowbar/wiki
>
>_______________________________________________
>Crowbar mailing list
>Crowbar at dell.com
>https://lists.us.dell.com/mailman/listinfo/crowbar
>For more information: https://github.com/dellcloudedge/crowbar/wiki



More information about the Crowbar mailing list