[Crowbar] nic issue on IBM servers

范鸿博 fhb1992 at gmail.com
Fri Jan 13 08:34:19 CST 2012


awesome!
I used to change the  /tftpboot/discovery/pxelinux.cfg/00-00-00-00-00-00
and set the  netcfg/choose_interface from auto to eth0. Your suggetion
seems better than my solution.
Thanks for your help!

2012/1/13 Byron Pezan <BPezan at secureworks.com>

>  i think you might need to edit either the preseed file or kickstart file
> depending on the OS you are deploying.  i’m dealing with something similar
> at the moment, except with hard drives for hadoop data nodes.  in my case
> (RHEL), i have to:****
>
> ** **
>
> edit the kickstart template
>                                             -
> /opt/dell/barclamps/redhat-install/chef/cookbooks/redhat-install/templates/default/compute.ks.erb
> ****
>
> reinstall the redhat-install barclamp
>                                              -
> /opt/dell/bin/barclamp_install.rb /opt/dell/barclamps/redhat-install****
>
> tag the host in question for re-install
>                                                      - crowbar machines
> reinstall de8-9a-8f-74-48-24.domain.com****
>
> wait for the kickstart file to update from the
> template                      - watch ‘grep “new text”
> /tftpboot/redhat_dvd/redhat_install/compute.ks’****
>
> reboot the system for
> re-installation                                                      - grab
> coffee, pretend to be busy****
>
> ** **
>
> as for how to tell the installation to use the default NIC instead of the
> USB NIC, that will depend on the OS.  for RHEL systems it’s the ‘network
> --device=eth1’ option in kickstart.  for debian/Ubuntu it appears that
> ‘netcfg/choose_interface select eth1’ might do the trick.****
>
> ** **
>
> you may have to manually boot into an install / live CD to determine which
> eth* device corresponds to your default NIC in order to set the right
> device value.****
>
> ** **
>
>
> http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-kickstart2-options.html
> ****
>
> http://d-i.alioth.debian.org/manual/en.i386/apbs04.html#preseed-network***
> *
>
> ** **
>
> HTH****
>
> ** **
>
> ** **
>
> byron****
>
> ** **
>
> *From:* crowbar-bounces at dell.com [mailto:crowbar-bounces at dell.com] *On
> Behalf Of *???
> *Sent:* Friday, January 13, 2012 8:18 AM
> *To:* crowbar at dell.com
> *Subject:* [Crowbar] nic issue on IBM servers****
>
> ** **
>
> My IBM server has a usb0 nic, and it is used as default NIC instead of
> eth0 when Crowbar admin is installing OS. However, the usb0 nic is used for
> IBM administration and isn't connected to the physical network.****
>
> How can I modify Crowbar so that it wouldn't use usb0 as the default nic
> when installing OS?****
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/crowbar/attachments/20120113/1ab6f7f4/attachment.html 


More information about the Crowbar mailing list