[Crowbar] failed to apply proposals in crowbar 1.2

Victor_Lowther at Dell.com Victor_Lowther at Dell.com
Wed Jan 4 09:52:31 CST 2012


Off the top of my head, that sounds like it could be a few of things. In order of likelihood:

1: /etc/resolv.conf is not pointing to the admin node for whatever reason.
2: named is not running on the admin node.
3: Named is running, and it can somehow talk to the real Internet and is horribly confused by the real openstack.org.

From: crowbar-bounces On Behalf Of Lu.YJ at inventec.com
Sent: Wednesday, January 04, 2012 12:59 AM
To: crowbar
Subject: [Crowbar] failed to apply proposals in crowbar 1.2

Hi all,

There is the issue described below. How to resolve it?

Issue: Failed to apply the proposal

Reproduce steps:

1.     Finish to install crowbar admin node (a VM) with openstack111219.iso (crowbar 1.2)

2.     Launch a node (a VM) to ready state (the node: d00-50-56-a5-00-0d.openstack.org)

3.     Create a proposal (with node d00-50-56-a5-00-0d) to mysql barclamp then apply it in crowbar web UI.

4.     Appear the error message "Failed to apply the proposal to: d00-50-56-a5-00-0d.openstack.org"

Root cause:
Could not resolve hostname d00-50-56-a5-00-0d.openstack.org

1.     View the log file d00-50-56-a5-00-0d.openstack.org.chef_client.log below in /opt/dell/crowbar_framework/log in the admin node
stdin: is not a tty
ssh: Could not resolve hostname d00-50-56-a5-00-0d.openstack.org: Temporary failure in name resolution
stdin: is not a tty
ssh: Could not resolve hostname d00-50-56-a5-00-0d.openstack.org: Temporary failure in name resolution

Workaround:
Can work around the issue by adding "192.168.124.81 d00-50-56-a5-00-0d.openstack.org d00-50-56-a5-00-0d" to "/etc/hosts" in the admin node

YJ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/crowbar/attachments/20120104/1076159d/attachment.html 


More information about the Crowbar mailing list